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Creating Simple Drawings

Draw. can create 2D and 3D objects. This chapter shows how to draw simple 2D 
objects; t. The following chapters describe working with and editing such objects.

All shapes, whether they are lines, rectangles, or more complicated shapes, are 
called objects, a common term in vector drawing software.

The drawing tools are found on the Drawing toolbar and on the Properties deck of the
Sidebar. Figures 1 and 14 show the icons common to the toolbar and the Sidebar. 
Additional icons will also be on the toolbar as installed with Draw.

As described in Chapter 1 (Introducing Draw), the Drawing toolbar is normally 
located at the bottom of the window and the Sidebar is at the right edge. If you do 
not see them, you can activate them from the View > Toolbars and View > Sidebar
menu. As in all components of OpenOfice, you can place the toolbar and Sidebar on 
the Draw window wherever you wish. Also, you can confgure the toolbar as you wish 
by adding, moving, hiding, or deleting toolbar icons.

Drawing Basic Shapes

Basic shapes include:

• Lines

• Arrows

• Rectangles and squares

• Ellipses and circles

• Curves and polygons

• Connectors

• Lines and arrows

Note
When you draw a basic shape or select one for editing, the 
Information feld in the status bar changes to refect the action taken 
or in progress: Line created, Text frame xxyy selected, TextEdit: 
Paragraph 1, Row 1, Column 8 and so on.

Figure 1 shows part of the Drawing toolbar with the icons needed in the following 
sections. The Text icon is also included. These same icons are available on the 
Sidebar.

Figure 1: Part of the Drawing toolbar

Drawing a Straight Line
We begin with the drawing of the simplest element—a straight line.

Click on the Line icon  and place the mouse pointer at the point where you want 
to start the line (see Figure 2). Drag the mouse while keeping the mouse button 
pressed. Release the mouse button at the point where you want to end the line. A 
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blue selection handle appears at each end of the line, showing that this is the 
currently selected object.

Holding down the Shift key while you draw a line restricts the angle of the line to a 
multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution This is the default behavior of the Shift key. However, if you have 
used Tools > Options > OpenOfce Draw > Grid to set Snap 
position to When creating or moving objects, the action of the Shift 
key is the opposite: lines will always be at a multiple of 45 degrees 
unless the Shift key is pressed.

Figure 2: Drawing a straight line

Keeping the Ctrl key pressed while drawing a line enables the end of the line to snap 
to the nearest grid point.

Caution The efect of the Ctrl key depends on the settings of the Snap to 
Grid option on the View->Grid menu:
Snap to Grid on: Ctrl deactivates the snap option for this activity.
Snap to Grid of: Ctrl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools > Options >
OpenOfce-Draw > Grid. See also Chapter 8 (Tips and Tricks).

Holding down the Alt key while drawing a line results in the line extending outwards 
symmetrically in both directions from the start point. This lets you draw lines by 
starting from the middle of the line.

The line just drawn has all the standard line attributes, such as color and line style. 
To change any of these properties, select the line by clicking on it, then right-click 
and select Line.

While you are working with a line (or any other element), you can use the information
feld on the status bar to monitor the activity. A description of the current activity or 
selection is shown when you are working with elements. Figure 3 shows two 
examples.

Chapter 2  Drawing Basic Shapes | 5

f c, 04/24/24
I don't see this behavior no matter how I set Snap to Grid

Mickie , 04/28/24
Reply to f c (04/24/2024, 10:25): "..."
Nor do I.



Figure 3: The information area in the status bar

Drawing an Arrow
Arrows are drawn like lines. Draw classifes arrows as a subgroup of lines, that is, : 
lines with arrowheads, but. Tthe information feld on the status bar shows them only 

as lines. Click on the Line Ends with Arrow icon  to draw an arrow.

Drawing Lines and Arrows

From the Lines and Arrows  icon on the Drawing toolbar or Sidebar, you can 
open a toolbar with ten tools for drawing lines and arrows (Figure 4). (Alternatively 
View > Toolbars > Arrows opens the toolbar as a foating toolbar.) In both cases, 
the last-used command will be stored on the toolbar to make it quicker to call it up 
again: click directly on the symbol to repeat the last used command chosen from this 
toolbar.

After drawing the line, you can change the arrow style by clicking on the Arrow 
button in the Line and Filling toolbar or on the Arrow box on the Line pane of the 
Sidebar,  and then chooseing from many arrow start and end options.
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1 Line 5 Line (45°) 8 Line with square/arrow
2 Line Ends with Arrow 6 Line starts with arrow 9 Dimension line
3 Line with arrow/circle 7 Line with circle/arrow 10 Line with arrows
4 Line with arrow/square

Figure 4: Arrows toolbar

Drawing a Rectangle or Square
Drawing a rectangle is similar to drawing a straight line, except that you click on the 

Rectangle icon , and the (imaginary) line drawn by the mouse corresponds to a 
diagonal of the rectangle, as illiustrated in Figure 5. In addition, the outline of the 
future rectangle changes shape as you drag the mouse around. The outline may be 
shown as a dashed line until you release the mouse button.

Figure 5: Drawing a rectangle

Draw considers squares to be rectangles with sides of equal length. Hold down the 
Shift key to draw a square. Hold down the Alt key while dragging with the mouse to 
create a rectangle with its center (rather than a corner) at the start point (where you 
frst clicked the mouse).

Note

Blue or green selection handles appear around an object made up of 
more than 2 points, showing that this is the currently selected object. 
The colors depend on the standard selection mode—green with a 
normal selection or blue if you are in the point edit mode. This efect 
is easily seen if both Simple Handles and Large Handles are 
switched on in the Options toolbar. See Chapter 3 for more details on 
points.
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Drawing Ellipses (Ovals) and Circles

To draw an ellipse (also called an oval) or a circle, click on the Ellipse icon . (A 
circle is simply an ellipse with both axes the same length.) The ellipse drawn is the 
largest ellipse that fts within the (imaginary) rectangle drawn by the mouse (Figure 
6).

Figure 6: Drawing an ellipse

There are three ways to draw an ellipse or a circle:

• Holding down the Shift key while dragging with the mouse draws a circle.

• Holding down the Alt key (together with the Shift key) draws a symmetrical 
ellipse (a circle) with the starting point at the center.

• Holding down the Ctrl key while dragging with the mouse draws an ellipse or 
circle that snaps to the nearest grid points.

Note

If you frst press and hold the Ctrl key down and then click on one of 
the icons for Line, Rectangle, Ellipse or Text, a standard sized object 
is drawn automatically in the work area: the size, shape, and color are
all standard values. These attributes can be changed later, if desired. 
This only works if the icon has no associated toolbar—no arrow on the
right side of the icon.

Adding Ellipse and Arc Tools to the Drawing Toolbar
You can add an Ellipse toolbar to the Drawing toolbar that allows you to draw 
circular or elliptical arcs:

1) Click on the arrow on the right-hand end of the Drawing toolbar and select 
Customize Toolbar.

2) On the Toolbars page of the Customize dialog, select Drawing in the Toolbar 
feld and click Add.

3) In the Add Commands dialog (Figure 7), select Drawing in the Category list, 
select the frst Ellipse command in the Commands list. You can confrm you 
have chosen the correct icon by comparing its description to the Description 
text in Figure 7. Click Add, and then click Close.
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Figure 7: Adding the extended Ellipse toolbar

4) On the Customize dialog, ensure that the checkbox by the new Ellipse 
command is selected, and then use the up and down arrow buttons to move it 
to the desired position on the toolbar.

5) To remove the simple Ellipse icon from the Drawing toolbar, click to highlight 
it in the Customize dialog, and press the Delete key (or click the Modify button
and choose Delete from the drop-down menu).

6) Click OK to complete the process.

You should now see this Ellipse icon  on the Drawing toolbar. If you use this 
icon instead of the standard Ellipse icon, all the extended ellipse functions are 
available. Clicking on the black arrow by the icon opens the foating Circles and 
Ovals toolbar (Figure 8). The icons are paired in columns. Selecting the icon in the 
top row draws a flled version of the shape and the bottom row draws and unflled 
shape. The arc shapes can only be unflled.

 

1 Ellipse 4 Circle Pie 7 Arc
2 Circle 5 Ellipse Segment 8 Circle Arc
3 Ellipse Pie 6 Circle Segmen

Figure 8: Circles and Ovals toolbar 
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To draw an arc, segment, or pie, choose the appropriate symbol in 
the Circles and Ovals toolbar. Drag with the mouse to create a 
guide circle or ellipse.

Release the mouse button and move the cursor to the position where
you want the shape to start. In the status bar, you can measure the 
actual angle in degrees. Single-click this point; the circle (or ellipse) 
disappears and moving the mouse creates the remaining part of the 
shape. Again, the status bar shows the current angle.

When you have drawn the shape to the length you want, click once 
more. The drawing of the arc is complete.

Curves
The tools for drawing curves or polygons are on the toolbar presented when you click
the Curve icon . This toolbar contains eight tools (Figure 9).

Note
Hovering the mouse pointer over this icon gives a tooltip of Curve. If 
you convert the icon to a foating toolbar, however, the title is Lines, 
as shown in Figure 9. 

Figure 9: Floating Curves toolbar (incorrectly titled “Lines”)

If you move the mouse cursor over one of the icons, a tooltip pops up with a 
description of the function. For a more detailed description of the handling of Bézier 
curves (curves and flled curves), see Chapter 10 (Advanced Draw Techniques).

• Polygons: Draw the frst line from the start point with the left mouse button 
held down. As soon as you release the mouse button, a frst corner point is 
drawn; move the mouse to see how subsequent lines will look. Every mouse 
click sets another corner point. A double-click ends the drawing. A flled 
polygon automatically joins the last point to the frst point to close of the 
fgure and flls it with the current standard fll color. A polygon without flling 
will not be closed at the end of the drawing.

• Polygon 450: Like ordinary polygons, these are formed from lines but with 
angles of only 45 or 90 degrees between them.

• Freeform Line: With this tool you can draw just like with a pencil. Press and 
hold the left mouse button and drag the mouse. It is not necessary to end the 
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drawing with a double-click. Just release the mouse button and the drawing is 
completed. If you have selected Freeform Line, Filled, the end point is joined 
automatically to the start point and the object is flled with the appropriate 
color.

Gluepoints and Connectors (Basics)

Gluepoints
All Draw objects have associated invisible gluepoints, which become visible when you

choose any of the connectors under the Connectors icon  on the Drawing 
toolbar and then move the mouse pointer over the object.

Most objects have four gluepoints, as shown in Figure 10. You can add more 
gluepoints, and customize gluepoints, using the toolbar of the same name (Figure 
11).

Figure 10: Four gluepoints

Figure 11: Gluepoints toolbar

Gluepoints are not the same as the little blue or green “handles” of an object. The 
handles are for moving or changing the shape of an object, as described in Chapter 3 
(Working with Objects and Object Points). Gluepoints are used to “glue” a connector 
to an object.

For a more detailed description of the use of gluepoints, see Chapter 9 (Organization 
Charts, Flow Diagrams, and More).

Connectors
Connectors are lines or arrows whose ends automatically interlock with a gluepoint 
of an object. Connectors are especially useful in drawing organization charts, fow 
diagrams, and mind-maps. Even when objects are moved or reordered, the 
connectors remain attached.

Figure 12 shows two Draw objects and a connector.
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Figure 12: A connector between two objects

Draw ofers a range of diferent connectors and connector functions. Open the 

foating Connectors toolbar by clicking on the arrow next to the Connector icon 
(Figure 13).

Figure 13: The Connectors toolbar

For a more detailed description of the use of connectors, see Chapter 9 (Organization
Charts, Flow Diagrams, and More).

Drawing Geometric Shapes

Geometric shapes include:

• Basic shapes

• Symbol shapes

• Block arrows

• Flowcharts

• Callouts

• Stars
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Note
If you select shapes for editing, the information feld in the toolbar 
shows the type of shape selected and, if more than one object is 
selected, the total number.

Figure 14 shows the icons referred to in the following sections. Clicking on the arrow
next to the icon opens a foating toolbar with the relevant work tools.

Figure 14: Part of the main Drawing toolbar

Tip The use of all these tools is similar to that of the Rectangle tool, even 
though they produce diferent geometric shapes.

Basic Shapes

The Basic Shapes icon  makes available a range 
of tools for drawing basic shapes, including a rectangle
tool identical to the one on the main toolbar.

The only diferences you will see are in the information 
feld in the status bar, in this case “Shape selected” 
rather than “Rectangle selected”.

Symbol Shapes

The Symbol Shapes icon  gives you an array of 
tools for drawing various symbols.

Block Arrows

The Block Arrows icon  opens the Block Arrows 
toolbar.
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Flowcharts
The tools for drawing fowcharts are accessed by 

clicking on the Flowcharts icon .

The creation of fowcharts, organization charts, and 
similar planning tools are described in Chapter 9 
(Organization Charts, Flow Diagrams, and More).

Callouts

Use the Callouts icon , to open the Callouts 
toolbar. (Callojuts are insets in a display; they serve to 
highlight a key excerpt or detail )

Stars and Banners

These tools are associated with the Stars icon .

You can add text to all these shapes. See “Using Text Elements in Draw Objects” on 
page 16.

Adding Text to Objects

Draw ofers two ways to add text to a drawing: in a dynamic text frame as an 
independent Draw object, or as text contained within a previously drawn object. In 
the latter case, the text is integrated with the object.

Using Dynamic Text Frames

The text tool is activated by clicking on the Text icon  for horizontal text or the 

Vertical Text icon  for vertical script (to be able see the icon and use this latter 
option, you must check Show UI elements for East Asian writings under Tools > 
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Options > Language Settings > Languages). If you still do not see the Vertical 
Text icon, enable it on the Drawing toolbar by clicking the arrow on the right hand 
side of the toolbar, select Visible Buttons, and click on Vertical Text to make this icon
show on the toolbar.

Text frames can be moved and rotated like all draw objects. For more details on text 
input, see Chapter 10 (Advanced Draw Techniques).

After activating Text command mode, click at the location where you want to position
the text. A small text frame appears. It contains only the cursor. You can move the 
frame, if desired. The Text Formatting toolbar appears (Figure 15) as do the 
Paragraph and Text panes of the Properties deck of the Sidebar, and you can choose 
the font type, font size, and other text properties and begin to type in your text.

Figure 15: Text Formatting toolbar

The text frame grows with text it contains. You can insert a line break with the 
Shift+Enter key combination; the Enter key begins a new paragraph. But neither line 
breaks nor new paragraphs terminate the text frame.

  

Figure 16: Text input in a dynamic text frame

Observe the information feld in the status bar: it shows that you are editing text and 
also provides details about the current cursor location—paragraph, line, and column 
numbers.

Text properties can also be changed during text input. Any changes will be refected 
from the cursor position onward (Figure 17).

Figure 17: Changing text properties

After choosing the Text icon, you can also draw a frame with the mouse to contain 
future text. You can move the frame only after typing some text in it. Line breaks are 
inserted automatically at the right edge of the frame when the text flls the frame 
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width (Figure 18). You can, however,—just as when editing any other text—insert 
your own line breaks, begin new paragraphs, or change any of the text properties.

Figure 18: Text frame

Using Text Elements in Draw Objects
A text element is associated with most Draw objects. By means of these elements, 
text can be added to an object (see Figure 19).

The exceptions to this are control elements like buttons or list boxes, as well as 3D 
scenes and their associated elements and groups.

If the Double-click to edit Text icon  on the Options toolbar is active, you can 
start editing an object by double-clicking on it (or by pressing F2). In the middle of 
the Draw object, a black bar indicates the text cursor; start typing to input text. The 
status bar shows “Text Edit” at the lower left and the position of the cursor within the
text.

Text can contain paragraphs, and these can be in the form of bulleted or numbered 
lists. To begin a new line without beginning a new paragraph, use the key 
combination Shift+Enter (as in text documents) . To end the text input, click next to 
the object or press the Esc key.

Figure 19: Adding text to objects
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